Talk:Deus Ex: Mankind Divided

About this board

DXMD's apparent problem with 8+ core processors

1
Gemma (talkcontribs)

hi,

had the problem that the game would enter an endless loading cycle after the cut scene when yo come back from G.A.R.M. googled it and not only found a solution after a short while, but more. apparently the game has trouble with too many cores/threads, unchecking threads 8-15 (keeping 0-7 active) through the affinity settings in the task manager i not only was able to continue my playthrough but the game even loads faster in any loading screen, so maybe that it something that could be added as a possible improvement?! i myself got an AMD Ryzen 7 2700x, the person i got that fix from has an AMD Ryzen X 1800, but they got it as a fix for Intel users, so it doesn't seem to be AMD specific.

Reply to "DXMD's apparent problem with 8+ core processors"

Fix for distorted aspect ratio and letterboxing/pillarboxing.

1
Catovitch (talkcontribs)

I haven't added this to the game as I do not have it myself to verify the problem is real and the fix works. However, I have used the same fix on two other games (AC:Syndicate and Watch Dogs 2), and the page for the fix I found says it also affects GTA V and Deus Ex: Mankind Divided. (Probably some other games as well.)

Maybe someone familiar with the game can decide if it's worth adding something similar.

Here's the original guide:

https://steamcommunity.com/sharedfiles/filedetails/?id=806615157

Here's what I added to the AC:Syndicate page:

https://pcgamingwiki.com/wiki/Assassin%27s_Creed_Syndicate#Incorrect_aspect_ratio.2C_letterboxing_or_pillarboxing

This is my first time using the wiki so I didn't want to add stuff I haven't confirmed, but the fix was a huge help to me, so I wanted to share it.

Reply to "Fix for distorted aspect ratio and letterboxing/pillarboxing."
Zemper (talkcontribs)

I always meant to make a Steam post about this, but unfortunately my graphics card died and I haven't had the time to re-research everything. But if somebody wanted to give it a shot (or, even better, write something up) I figure I'd get a quick post out about a couple of fixes I used to get around crashing on my (shouldn't have been based on the requirements) lower-end computer. It's important to note that one of these methods worked well for me, but I forgot which one in particular.


The first was to use in-game settings to force windowed mode, and then edit one of the ini files to force it to use a render resolution LOWER than what was possible using the in-game settings. On top of that, the display resolution was different, so you could essentially do whatever the opposite of supersampling is (upsampling? Upscaling?) as long as you could tolerate a blurry mess. I remember in particular that this would break the windowed mouse support for things such as the hacking minigame, and going to the video options would reset it unless the ini was protected.


The second was to use a framelimiter (like Nvidia Inspector or whatever it's called) to lower the framerate to ~30FPS. Actually the original idea behind this wasn't just to ease the stress on the card. The original idea was that if the port was a bit funky, it would target the original framerate for consoles, which is 30FPS locked. I should note that my card never got below 30FPS at any time normally.


Deus Ex: Mankind Divided still has crashes posted about today (including popular ones like the guard/subway area during the first hub) which I've gotten past. But, of course, no promises that these will work!

Reply to "Potential fixes to crashing"

Regarding the save game issues (EXE version 1.0.524.7): Possibly a Steam cloud bug!

2
God ownerOfTheUniverse (talkcontribs)

HELP! Organizer, please delete this thread, issue has been solved / added to article.


I saw this: (didn't really play myself yet)

https://steamcommunity.com/app/337000/discussions/1/355043117528654702/#c352792037311648900

It says that DX:MD seems to completely ignore one's Steam cloud sync preferences. Even if they're turned off (globally and also in the app settings), after about 148 saves the cloud space says about 950MB are used and about 9MB free. And that's when saving stopped working altogether. (Btw. a savegame is about 50MB in size.)

The poster tried to edit remotecache.vdf to refer only to the most recent saves (after he removed the rest of them) in the steam\userdata\(u_id)\337000 folder, but this didn't help. Tried clearing all caches which successfully emptied the cloud storage, and the game then said that there were indeed no saves at all, even though the few most recent local saves were there. (Again, both cloud sync settings were set to OFF.)

The guy then started a new game and created a savegame or two. The cloud info showed that apparently, those files were then being uploaded into the cloud even though that should be IMPOSSIBLE. Starting Steam in offline mode didn't help, because now the newly created savegames could not be loaded - that seems to be bound to cloud storage somehow.

The guy can't continue playing the current campaign because he can't use those save games because the cloud is full. "Editing" the cloud content does not help - only wiping works, but then obviously the campaign is gone.


Mirh (talkcontribs)

Don't really know what the issue in this game is about, but if I were you I'd check this

Reply to "Regarding the save game issues (EXE version 1.0.524.7): Possibly a Steam cloud bug!"

Max FOV too low, is 90-100° tops (in 16:9), can't be adjusted via Registry.

3
God ownerOfTheUniverse (talkcontribs)

HELP! Organizer, please delete this thread, issue has been solved / added to article.


DX:HR's FOV could be set to a value that exceeded the max in-game value (as long as you didn't visit that options-page afterwards), and DX:MD's settings, too, are in the Registry:

HKEY_CURRENT_USER\SOFTWARE\Eidos Montreal\Deus Ex: MD\Graphics

But changing the key "FOVCorrection" to something higher does not increase the FOV further. (The value has effect, though: Setting it very low reduces the in-game FOV to the minimum the game allows.)

You can see that it's about 90-100° by standing with your back in a 90° corner and being able to *almost* see the left and right walls of the corner.

Are there any solutions to this? Any tricks? Will the devs hear us and increase the max value, a task that can't take more than 20 minutes? Does anyone know?

For the record: I also made a Steam thread, but I guess we should keep the discussions separate. Because here, we'll probably be entirely constructive and tech based, while there we'll have the usual meddling of people who hate other people's freedom. http://steamcommunity.com/app/337000/discussions/0/355043117526379308/

EDIT:

Well, that thread spawned an obvious but brilliant idea: Cheat Engine. Assuming that the in-memory value is the same as the one written to the Registry, we could step through the FOV slider via keyboard to achieve a few reliably reproducible positions, write down the Registry values (possibly having to quit each time, not sure), and then finally hunting for these values in memory by changing the FOV slider.

EDIT:

A Steam friend's friend made a working Cheat Engine script. I edited the FOV section accordingly. It's a bit rough, but we're working together on this, right?

EDIT:

Thanks to Garrett for properifying everything. But alas, I had to remove the Cheat Engine script because the one who gave it to me and had OK'd the publishing (I have screenshot/save of Steam forum page.) told me hours later that his friend who made it does not approve and to remove it. D:


Suicide machine (talkcontribs)

If there is an FOV slider, than it's very unlikely a Cheat Engine script is even needed as the value for it is stored somewhere - most likely in either of these 4 methods:

  • Horizontal degrees
  • Vertical degrees
  • Horizontal Radian value
  • Vertical Radian value

Hence, doing it via script is probably a needles overkill.

God ownerOfTheUniverse (talkcontribs)

I don't know enough about Cheat Engine to answer this. I guess that the script would ensure that the value is set again and again, preventing the value from being reset (e.g. maybe between area changes).

The value I saw in the script "UI" said "1.25" and I guess I set it to "1.5" for testing. That is the PERCENTAGE value of the slider, I guess.

...

Surprise, the intermediary is in the chat again, saying that he now has a FOV only script.


Reply to "Max FOV too low, is 90-100° tops (in 16:9), can't be adjusted via Registry."

Manual configuration of mouse sensitivity below 0%

4
DoerOfThings (talkcontribs)

NorthernLunatic posted his findings at reddit.

  1. ) Use IEEE-754 Floating-Point Conversion to calculate your desired sensitivity.
  2. ) Input your desired Decimal Floating-Point value (eg. 0.15) and click Rounded.
  3. ) Use the Single precision (32 bits) Hexadecimal output.
  4. ) Reverse it so 3E 19 99 9A becomes 9A 99 19 3E
  5. ) Download HxD Hexeditor
  6. ) Open <Steam-folder>/userdata/<user-id>/337000/remote/game_options.bin> in HxD
  7. ) Replace bytes at offset 220-224 with hexadecimal values:
0.025 CD CC CC 3C 
0.05  CD CC 4C 3D 
0.1   CD CC CC 3D 
0.12  8F C2 F5 3D 
0.15  9A 99 19 3E 
0.175 33 33 33 3E
God ownerOfTheUniverse (talkcontribs)

Thanks for all that (especially for the risk since you still possibly want to refund). Do you have any idea why some settings are in that binary file and some are in the Registry? Are there possibly some in the binary that are also in the Registry (like e.g. ... FOV)? I'd ask in the Reddit post, but I'm banned there :P


DoerOfThings (talkcontribs)

I'm not NothernLunatic I just posted his findings & how to use them here incase it never gets patched. I'd guess settings in the Registry are from the nature of the engine being multiplatform and the .bin is stuff Nixxes added doing the PC port. Not sure about FOV yet.

God ownerOfTheUniverse (talkcontribs)

That might be so. ... Got unbanned, commented there. If I find significant answers, I'll sure PCGW them.


Reply to "Manual configuration of mouse sensitivity below 0%"
There are no older topics