Topic on Talk:Red Dead Redemption 2

Fix for "ERR_GFX_STATE" error after new update

9
Infogram (talkcontribs)

Started getting this error after the new update whenever I loaded into a save, after some investigating I found deleting the sga_vulkan_final_init files (should be 3 of them) inside "Documents\Rockstar Games\Red Dead Redemption 2\Settings" would let me load in without any issue (game regenerates them when they don't exist), seems like I need to do this each time I want to start the game though...

I'm not really sure if this is just something to do with my setup or not so didn't add this to the article yet, made a few posts on reddit about it though so I guess we'll see if it helps any others.

Infogram (talkcontribs)

Well I've had two confirms from other people that this lets the game work for them (seems this issue is kinda rare already so I can't really expect tons of responses), but now that I'm pretty sure this isn't just something on my end I'll add something to the article about it in a sec.

E: also, another small issue with the new update: some reason the settings button is grayed out on the main menu now, need to wait 10-20 seconds for it to enable itself... not sure if that's worth a mention in the article or not though, but there's been lots of people asking about it on the subreddit (previously the button was always enabled, dunno why they changed it)

Infogram (talkcontribs)

Strange, after playing for a bit and making a new save, now I can play the game fine with the sga_ files in place, no need for me to delete them now.

I guess maybe it had something to do with where I saved it before? Unfortunately can't remember where my save was when I was getting the crash, will have to try checking some older saves.

If this is the case I guess it should be added to the article? Since this'd mean you don't need to delete the sga_ files each time, just delete them once, load in, and save in a different location. I'm still not completely sure the location is what caused it though...

EDIT: aha, found my old save and yep, the crash still happens with it, so I guess that must mean the problem is location-based?

For reference, my chara was located at the bottom-left of the "N" in "LEMOYNE" on the map: hxxps://i.imgur.com/JpDeq7D.jpg (can't post URL for some reason...)

Would be interesting to see if anyone else gets an error there with the cache in place.

E2: Loaded my crashy save with sga_ files deleted, moved to a different area and saved game, then restarted with sga_ files from last run, and it loaded in fine!

Added a mention about needing to relocate to the article, would still be nice if someone else can try saving at that location I posted and see if they also get a crash in Vulkan mode though.

Rose (talkcontribs)

"Fixed it by going into Online (because that worked for some reason) and then loading my single saved game from there, and it worked after that."

From this comment.

Does it help? It would be better than removing files.

Infogram (talkcontribs)

Just gave it a try and seems not :( Switched to Online on the menu and tried loading in, load screen showed up for a few seconds but then gave the same error.

(strange that my bugged SP save would effect the online part, maybe because I haven't set up my online chara yet or something...)

Removed the cache files & tried again, and it loaded in fine.

Too bad, that would have been a better fix. Sounds like it can help for some people though, could still be worth mentioning it I guess.

Rose (talkcontribs)

There is not much evidence for it that I'm aware of. Thanks for adding the main fix to the article though. Since the addition, I've seen multiple reports of people saying it works.

98.255.25.124 (talkcontribs)

I just created a batch file to cd to the "Settings" folder and del sga_* and then launch RDR2.

2600:100C:B023:E8AA:506:8333:AE9C:7193 (talkcontribs)

I have been having the same issue using Vulkan API. Deleting sga files has worked thus far, but sometimes it just loads fine, and I believe the location based theory is correct. I saved near clemens point after hunting iguanas where the pirate hat is located on that island, and then closed. When I tried to load it next time I booted it up, it was crashing on me. This happened early on when I first started playing, so it was very strange this time. But I deleted the sga files, and reloaded, and instead of freezing with basically a white screen as before, it piece mealed in different parts of where I was, meaning the land first, then fog, then half of arthur's body, the particle physics (like the flies above the water) and then the rest loaded in, and I was able to play. It is stupid that u am playing so slowly bc I'm afraid my game will crash somewhere, and I am saving after everything I do, like picking herbs, or random person run into. I have taken to saving at back at camp, because camp has loaded up each time so far, and hopefully it continues to. Or hopefully, they figure out wth is going on and fix IT. This white screen crash when loading seems to only happen with Vulkan, because when it happened initially, I switched to DX12, which loads fine, but crashes every time I try to enter thru Valentine's town from the meat seller/horse stall side of town. I believe this post is true to why the crashes are happening.

2600:100C:B023:E8AA:506:8333:AE9C:7193 (talkcontribs)

Also, when I was loading up after my save, it was loading at clemens point. The gang camp was still back at horshoe overlook, early in the story mode

By clicking "Reply", you agree to the terms of use for this wiki.