Talk:Mass Effect

About this board

Mouse acceleration and deceleration/dampening

2
79.136.94.132 (talkcontribs)

This has been an issue since release and can't find any solution for it. Here's a video to see how it looks like http://www.youtube.com/watch?v=do_llujhc1Y If anyone has managed to fix it please spread the knowledge

Mirh (talkcontribs)

To check

Also, schematics here and here. Discussion thread here.


EDIT: putting aside the majestic fix by Methanhydrat, I'm still banging my head over what's actually wrong in the game code. And with ME3Explorer's incredible advances, I could dig up way better inside packages (even though it's still not perfect: for example I can not find any usage whatsoever of the m_fCamStickScalar property of BioCameraBehavior.. but if you set it to 0 the in-game camera stops to work)

And it's really a mess, as good old Dybuk reported while developing the controller mod. Not that having different BioCameraBehaviors on top of BioPlayerController on top of BioPlayerInput on top of PlayerInput (on top of Input?) was bound to be easy already, but spaghetti code with convoluted ifs really doesn't help.

Anyway, speaking of the latter class, I have confirmed bEnableMouseSmoothing is indeed at least doing something. It's not enough though of course.

Therefore, devoid of ideas, I shot in the dark and tried to compare the scripts with ME2 code.. And while there really isn't anything similar to the PreProcessInput function where ME2 employs the definitive bUseMouseDampening (or any other similarity whatsoever between BIOC_Base and SFXGame), the Engine file was basically identical as far as I could care.

Except the PlayerInput function in ME1 is missing a mysterious multiplication by the Outer.CustomTimeDilation object. Thus I'm left wondering if the culprit for mouse acceleration couldn't be this triviality, or what else is hiding in the other haystack.

EDIT2: lol

Reply to "Mouse acceleration and deceleration/dampening"
79.45.76.17 (talkcontribs)

I can't reproduce the nvidia crash mentioned under issues fixed. It was either fixed by nvidia or the issue was caused by mods

Reply to "Nvidia crash?"
2601:281:203:4716:4989:9017:57C:981D (talkcontribs)

Origin now appears to accept Steam keys without contacting EA support like ME.2

Reply to "Steam cd key activation on Origin"

Can't use "Mass Effect Mouse Fix" with "FPS Counter And Post Processing Effects" mod

1
Unger Games (talkcontribs)

Installed the Mouse Fix mod, then the mouse fix's .dll file got overwritten by FPS counter's .dll when I installed that.

There's a "Loading Other Fixes/Mods/Injectors" section on the Mouse Fix page, but I tried both methods (file and folder) and the FPS Counter .dll was disabled in both cases.

Does anyone have a workaround for this?

Reply to "Can't use "Mass Effect Mouse Fix" with "FPS Counter And Post Processing Effects" mod"

Mass Effect on Steam, having to run Steam as admin

5
Todpullen2 (talkcontribs)

I discovered after installing ME1 via Steam that I only had to run Steam as administrator once, after that first time I started the game I could reset Steam back to its vanilla compatibility (not admin) and the game starts and runs fine (so far). Having Googled I found a few forum posts mentioning this, but most places (including this Wiki) seem to imply that you need to leave Steam with Admin permissions.

Anyone else found that you only need to start Steam as Admin once? Or the opposite that you need to leave it as Admin all the time you want to run Mass Effect ? Not sure this should be mentioned in the Wiki page if common, but some people may well prefer not to have Steam run as Admin all the time

Mirh (talkcontribs)

i can confirm this

Todpullen2 (talkcontribs)

OK I have added a small change to the main page, if anyone objects just reverse the edit. I have no idea what affects whether you need to have Steam as admin just once or all the time. If anyone finds out what makes the difference do let us know!

Mirh (talkcontribs)

probably, it need to set right files permission or write some entry in the windows registry

if you want to investigate further, i would suggest you to try regshot it's a nice program which compares windows registry before and after a determinate event

Mirh (talkcontribs)

ok, i had this problem again.. and after some investigations i found the issue
the game CAN'T load the physx runtime... if you change your MAC address!

yes, i'm talking exactly of that string that univocally identify your network device :|


it seems that IF the game find a "newer" network card which doesn't match the MAC address stored inside the enableLocalPhysXCore binary value at HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\AGEIA Technologies (or if you are launching the game for the first time) the game simply refuse to load its own .dlls
instead it will look at C:\Program Files (x86)\NVIDIA Corporation\PhysX\Engine\v2.7.2\, which will be empty, unless you also installed legacy PhysX.

so, you have 2 choice:

  • enter the windows registry and fix that entry (running the game as an admin automatically does the same thing)
  • or copying PhysXCore.dll from the MassEffect/Binaries folder to the physx one i have talked above


EDIT: with W10 default mac address randomization this gets even more messed up
EDIT2: more plot to the thing! It seems that every game patch/dlc installer contained a small VistaFirstRunFix.exe utility, extracted in %COMMONPROGRAMFILES(X86)%\Bioware\. Then, I'd guess it was easy as pieing running it with admin rights and doing whatever dirty fix explained above

Reply to "Mass Effect on Steam, having to run Steam as admin"
Mirh (talkcontribs)
Reply to "New controller mod"
Mirh (talkcontribs)

[BIOC_Base.BioSaveGame] and [BIOC_Base.BioGamerProfile] inside BioGame.ini seems rather newsworthy
Especially m_bIgnoreDLCRequirements if, like me, you are trying to mess up with the game settings instead of playing it

<path-to-game>\BioGame\Config\DefaultGame.ini has even comments to further understand the options

Reply to "Interesting ini values"
58.172.218.30 (talkcontribs)

Controller support is mentioned, but the ME-specific fixes that work aren't mentioned, just a link to the general Using Controllers On Games That Don't Support Them page.

Since this is such a common issue, and the best solutions are ME-specific solutions that add support beyond what xPadder etc can do, I'd like to add a section on that, is there some reason there isn't one already? misapplication of a blanket rule about controller-support-adding tips?

Andytizer (talkcontribs)

No particular reason why it isn't in yet - just remember that we are a young wiki (less than 1 year old) and we don't have that much editing activity.

A full controller support section for ME series would be greatly appreciated.

Garrett (talkcontribs)

I have added a basic explanation of the controller fix for Mass Effect. Feel free to correct/improve it. :)

Reply to "Controller Support"

Game Needs Access To The Internet To Verify Ownership

1
66.214.86.198 (talkcontribs)

I've tried changing the compatibility of the Mass Effect file in the Binaries folder, but it still doesn't work. I've checked my firewall and it isn't blocking any outgoing connections related to Mass Effect or Origin. I've restarted twice as well. Anything else I can try?

Reply to "Game Needs Access To The Internet To Verify Ownership"
There are no older topics